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1 Introducing Rapture3D
Thanks for using Rapture3D! Rapture3D works with computer games and ambisonic audio playback to give a full
3D surround sound experience.

This is help for the standard ("User") edition of the software. It should be possible to make it work with quite a
few OpenAL games, although some quite dangerous technical intervention can be required. There are "Game"
and "Advanced" editions too.

1.1 Getting Started

Generally, Rapture3D will just work with your sound card settings, so if sound is working on your PC then you're
probably ready to go. Although you may want to check your Windows "Advanced" sound card settings because
Rapture3D works best when it knows exactly what kind of speaker layout (or headphones) you are using.

Once your sound card is set up, Rapture3D will choose sensible settings for your PC. But you may wish to use the
Rapture3D Speaker Layout tool to tune things further so the sound is just as you'd like it.

1.2 The Rapture3D OpenAL Driver

For some games, the Rapture3D OpenAL driver can be used in place of the system OpenAL driver to take
advantage of Rapture3D's sophisticated 3D audio rendering.

1.3 The Rapture3D Ambisonic Player

Rapture3D comes with a player for ambisonic sound files (typically .AMB files). Unlike standard "surround"
mixes, these can reproduce full 3D audio.

Copyright 2015 Blue Ripple Sound Limited 1



2 Sound Card Set Up
Your sound card was probably set up when you bought it, although the settings may have changed depending on
what you've connected to it since. If your computer can play music or films with sound, make telephone calls or
even just play the Windows "welcome" jingle then you're probably ready to go.

You need a DirectSound-compatible sound card for this edition of Rapture3D to work properly. This is the
normal type for Windows, so if other sounds are working then Rapture3D probably will too. If not, then it's
probably best if you talk to the shop where you bought your computer (or a friendly expert) before continuing
here. To avoid embarrassment, you might want to check you've connected up your speakers or headphones
correctly (the instructions probably came in the box with your PC).

Rapture3D works best if it knows exactly how your speakers are set up. If you're feeling brave, you can
"Configure" your Windows sound card to choose the layout you want. This is particularly important if you're
using headphones or a "surround sound" system with more than two speakers. On some systems (but not all) you
can also check and change these through the Rapture3D Speaker Layout tool using the Layout tab.

2.1 What Is A Sound Card?

Once upon a time, a sound card used to be a computer expansion card (a circuit board) that was slotted into the
back of a PC to produce sound. These days the electronics needed is often built into the main body of the PC or
connected using USB, so there isn't really a "card" involved at all. But we often still call the electronics involved a
"sound card" anyway.

Sound cards typically have connectors to allow you to hook up speakers or headphones, although some work with
internal speakers, particularly in laptops.

If your computer produces sounds at all, your sound card is probably ready to go, though if you want to use more
than two speakers you should probably delve deeper...

2.2 Advanced Sound Card Set Up

Windows "Control Panel" is normally available from your Windows "Start" menu. Within this, depending on how
you have it set up and your operating system, you will see a section with a names like "Sound", "Sounds, Speech,
and Audio Devices" "Sounds and Audio Devices" or "Hardware and Sound".
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When this is selected, you should see something like one of these:

If you click through the tabs, you should see the audio settings you're using for other audio playback. If they don't
look right, change them if you're sure you know what you're doing, or find an expert to help.

Once you're done, click on the "Configure..." button if it's enabled (or "Advanced..." on Windows XP). This
should bring up another window as below. If it doesn't, or if the button isn't enabled, don't panic - it's probably
just that your sound card is stereo only but doesn't understand that there are different types of stereo. You can
configure this more precisely in the Rapture3D Speaker Layout tool by using a Stereo Compatibility ("Compat.")
mode on the Layout tab. There is a similar compatibility mode for ITU 5.1, primarily for use on XP.

The important thing here is the "Audio channels" setting, or the "Speaker setup" choice on Windows XP. This
should be set as close as possible to the actual layout of the speakers you're using. Again, if you don't have the
right stereo options available you may want to use a Stereo Compatibility ("Compat.") mode on the Layout tab.

Click on "OK" when you've finished making changes, or "Cancel" if you want to leave things as they were.
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3 Rapture3D Speaker Layout
Once you're happy that your sound card is set up correctly you might want to fine-tune the settings using the
Rapture3D Speaker Layout tool. Normally this appears under "Blue Ripple Sound" on your Windows "Start"
menu.

Set up is done in stages, each with its own tab:

On the Layout tab, check your sound card has been set up correctly and that the speaker (or headphone)
layout is correct.

1. 

The Decoder tab can be used to select the decoder that will be used for the layout chosen on the previous
tab.

2. 

On the Rapture3D tab, you can choose the settings that will be used when a game is running.3. 

Normally license set-up happens automatically, but if it didn't or if you want to move a license to another
machine, you can use the Licenses tab to manage your Blue Ripple Sound licenses.

Click on "Apply" or "OK" when you're happy with your changes, or "Cancel" if you want to leave things as they
were. Note that if there is a game running when you do this, Rapture3D will attempt to restart itself, so make sure
you save your place first as some games may not like this.

If your Windows sound card settings are correct then Rapture3D generally will choose sensible settings for your
machine, so none of this is necessary. But we think the flexibility this program provides is useful and interesting!

Oh, there's an About tab too, with information about us (Blue Ripple Sound), the edition of the software you're
using and other third-party software we've used, plus some legal stuff. Please read!
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3.1 The Layout Tab

As you can see above, most of this page is taken up with a graphical representation of the speaker layout you're
using. You can click and drag to rotate the graphical view (this doesn't affect the sound).

The speaker layout displayed should correspond to your Windows settings. If you change the layout on this page
using the "Layout" drop-down at the top, you may also need to change your Windows settings. We'll try to change
them for you automatically, but often this isn't possible, so you (or a friendly expert) might need to use Windows
"Control Panel" to change some soundcard settings.

3.1.1 Layouts

Rapture3D comes with support for the following layouts:

Stereo This is a straightforward layout using two speakers that many people use.

Headphone
Stereo

This is what should be selected if you're using a set of headphones. If you've connected
headphones but Windows won't let you select this then take a look at the Compatibility Modes
below.

Mono Just one speaker is available. Obviously there's not much we can do in 3D here!
Quad Four speakers at the corners of a square.

Surround 5.1

This is an arrangement with front left, right and centre speakers and two "surround" speakers at
the side or back. There's a subwoofer too, which can go anywhere in the room. This layout
assumes that the four corner speakers are set out roughly in a square, which is slightly different
to the "standard" ITU layout below. We find that many gamers and sound positioning systems
use this.

Surround 5.1
(ITU)

This is a version of the "Surround 5.1" layout that you may well have set up if you're following
cinema conventions rather than gaming ones. This layout has larger gaps between speakers to
the side and rear, as recommended by the ITU (International Telecommunication Union).
Specifically, your front left and right speakers are expected to be 30 degrees from front centre
and the "side" speakers at 110 degrees. Anyway, try changing the Layout drop-down between
the options and see which one looks most like the actual layout you're using. Don't worry about
the location of the large "subwoofer" in the picture - this can go anywhere in the room.

Surround 7.1 This adds two more speakers beyond Surround 5.1, so there are two side and two back speakers.
Surround 7.1

(Wide)
This is a widescreen speaker layout used in some cinemas, where placement of sounds across
the screen for many viewers is prioritised over immersion and front/rear balance.
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Surround 3D7.1

This is a new layout that takes a bit of effort to set up, but is well worth the effort as it allows
sounds to be placed above and below! (It works fine for stereo and 5.1 films too.) For this to
work, you need your computer set up to use 7.1 surround speakers, but you don't put the 7.1
speakers in their normal places. See here for more detail.

Surround
Stereo

It's possible you have your computer set up using stereo (i.e. two channels) but you're feeding
the audio to another box with a "surround decoder" which will do some clever stuff and then
feed to more than two speakers. "Dolby Pro Logic" is an example of this. If you select this
option in Rapture3D we'll try to generate a compatible signal (make sure you select the right
"Method" on the "Decoder" tab though). These systems typically don't work as well as feeding
the surround speakers directly, but they aren't bad.

Compatibility
("Compat.")

Modes

Some Windows sound cards don't know the difference between different types of stereo
(ordinary Stereo, Headphone Stereo and Surround Stereo). This is because the difference
doesn't really matter to them - they just output two channels of audio and call this "Stereo".
However, this matters to us. So if you've connected up headphones and your sound card lets
you select "Stereo" but not "Headphone Stereo", select "Headphone Stereo (Compat.)" instead.
This will tell your sound card that you're using Stereo, but Rapture3D will know the difference.
There is a similar compatibility mode for ITU 5.1, primarily for use on XP.

3.1.2 Checking Things Out

Once you've selected the correct layout, it's worth checking to see if sounds are really coming out of the correct
speakers. To do this, select the channel you want to test using the "Channel" drop-down (the relevant speaker will
light up in the picture), check the volume levels on any external amplifiers or suchlike - and click on "Test
Channel". You should hear a "bing" noise from the correct speaker. If it comes from the wrong one then I'm afraid
you need to go check your wiring. Sorry...

Sounds should be roughly at the same level from all speakers, so if you have any external amplifiers you might
want to tune them.

If everything looks okay on the Layout tab, you're probably good to go. But you might want to proceed to the
Decoder tab for more control over how things sound...
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3.2 The Decoder Tab

Things start to get a bit more technical here, but bear with us and it'll hopefully be worthwhile.

To start with, there's a volume slider at the top of this screen. This slider sets the overall level used by Rapture3D
when it's started up. Note that this is an additional control - it's separate from the main Windows volume setting,
any volume controls in the game you want to play and any settings on external amplifiers etc. In general, you
should just leave this control alone (at 0dB) and use the other ones.

There's also a "View Logs..." button at the bottom of the screen. Don't worry about this unless you need to
troubleshoot. (It provides technical details about things that happened when Rapture3D was last used.)

Then there's the "Method" drop-down. The exact list of items available here depends on what you selected on the
Layout tab. For instance, the "Reconstruction" option in the picture above is available for multi speaker
arrangements (e.g. Surround 5.1) but not for Stereo or Headphone Stereo, which have some thoroughly different
options. Whichever option you select, the text below the drop-down describes how this method will work. Try
flipping through the options to see what you're choosing from. Some of these options make quite noticeable
differences to how things will sound when you actually start a game up that's using Rapture3D.

3.2.1 Decoder Methods

Since you can flip through anyway, we'll just describe some of the concepts here so they make a bit more sense.
Decoder methods have a variety of pros and cons. Some of them use more or less CPU power, some of them are
more or less sensitive to how accurately you've set your speakers up and some of them actually will work better
for people with differently shaped heads! The best thing to do is to try some and listen...
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3.2.1.1 Headphone Stereo Methods

Several of the headphone decoders use HRTFs. HRTFs tell us how sound travels past a human head and into the
ear and provide a great way to provide a realistic sound image over headphones. However, human heads are not
all the same shape! We provide six different HRTFs - you might like to try these out to find the one that works
best for you. At best HRTFs can place sounds anywhere, including behind and above. However, if they don't
really match your head shape you may find "confusion" occuring, with sounds that should be behind appearing to
be above etc. If you find this happening, try a different HRTF.

HRTF HRTF-based headphone decoders using psychoacoustic cues to present sounds in full 3D.
Amber is often a good choice.

Simplified HRTF
(Amber)

Version of the Amber HRTF, massively simplified so it is is not frequency-dependent. This
places relatively light load on your CPU.

Panner This splits sounds between the left and right ears using carefully optimised panning
functions. This places relatively light load on your CPU.

The HRTFs provided are based on academic data sets available on the Internet - thanks to all involved! They've
been processed for use with Rapture3D, so any problems are entirely our responsibility. We've given the data sets
colour names like "HRTF (Red)" for simplicity, but you can see where the HRTF actually came from in the text
shown on this tab.

If you don't want to use an HRTF data set you can just select "Panner". This will provide a perfectly serviceable
plain stereo image. You can save a few CPU cycles this way too, although the simplified HRTF is no more
expensive.

3.2.1.2 Stereo Speaker Methods

If you're just using a normal stereo system then "Panner" is probably what you want here.

Panner This splits sounds between the left and right speakers using carefully optimised panning
functions. This places relatively light load on your CPU.

HCTC Stereo HRTF-based Cross-Talk Cancellation. Requires accurate speaker set up at an angle of 50
degrees.

HCTC Stereo
(Narrow)

HRTF-based Cross-Talk Cancellation. Requires accurate speaker set up at an angle of 20
degrees. Amber only.

The HCTC Stereo options can work well if your speakers are set up very accurately and if you don't move your
head much. They're not suited for use with multiple listeners. They're also dependent on you finding an HRTF
data set that works okay for you (the same problems apply as described for HRTF headphone stereo above). But
they're well worth a try, particularly if you're using desktop or laptop speakers.

But - why only two speakers? To get the best out of Rapture3D you could try using a sound card that lets you
connect more...
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3.2.1.3 Multi Speaker Methods

If you're using proper surround sound systems with four or more speakers (e.g. 5.1, 7.1 or 3D7.1) then these
options are available:

Basic
This method produces a resilient decoding which should play well on a range of speaker
systems including large venues. It should be used if your speakers are only roughly in the
right places or if your CPU is struggling to keep up.

Reconstruction
This is the default setting. It produces a solid image and uses a sensible amount of CPU
power. It relies on the speaker layout being set up accurately and is optimised for a domestic
or studio listening environment.

Tinted
Reconstruction

This is a more expensive option in CPU terms, but performs HRTF-based tinting on the audio
stream to strengthen the spatial image. For some people, this can even give a sense of sounds
being above and below when all speakers are all at the same height!

For layouts with a front centre speaker, there are variants of the methods above. This is because, for compatibility
with speaker sets with a special dialogue front centre speaker, the front centre speaker is used usually for dialogue
only.

Basic (Front Pan)
Reconstruction (Front

Pan)
Tinted Reconstruction

(Front Pan)

As above, but use the front centre speaker for panning as well as dialogue. Use this if
you are confident that your front centre speaker has the same response as the others.

3.2.1.4 Surround Stereo Methods

These are offered if you selected "Surround Stereo" or "Surround Stereo (Compat.)" options on the Layout tab.
Just select the method that matches the surround decoder you are using. If none match, you probably want to
switch your layout back to ordinary Stereo.

Dolby Pro
Logic

This is compatible with Dolby Pro Logic decoders. Your decoder may be able to make use of a
centre speaker and one or two surround speakers at the back of the room.

Dolby Pro
Logic II

This is compatible with Dolby Pro Logic II decoders. Your decoder may be able to make use of a
centre speaker and two surround speakers at the back of the room.

Dolby Stereo This is compatible with Dolby Surround decoders. Your decoder may be able to make use of acentre speaker and one or two surround speakers at the back of the room.
Matrix QS This is compatible with Matrix-QS decoders. These are fairly rare.
Matrix SQ This is compatible with Matrix-SQ decoders. These are fairly rare.
UHJ Stereo This is compatible with ambisonic UHJ Stereo decoders. These are fairly rare.

Note that the encoders used here aren't all "official" ones. They should be compatible though.

Copyright 2015 Blue Ripple Sound Limited 9



3.3 The Rapture3D Tab

Here's where gaming settings are selected. You can tune these to make the best use of the hardware you have
available. If in doubt, just press the "Set Defaults" button to choose settings that make sense. If quality setting are
too high, you may find that audio "skips" or other parts of the game such as the graphics engine struggle to keep
up and become jumpy.

3.3.1 Spatialisation Quality

This determines the quality of spatial rendering (3D sound) used by Rapture3D. Note that this control works on
conjunction with the actual decoder method chosen on the Decoder tab.

3.3.2 Processing Quality

This determines the quality of effects processing and sample rate conversion used by Rapture3D.

3.3.3 Masquerade as Standard Driver

These options allow Rapture3D to "pretend" to be the Generic Software or Generic Hardware OpenAL drivers.
This is quite technical and dangerous and should only be enabled if you're really sure you know what you're
doing.

The reason that using these switches is dangerous is because, to make them useful, you also need to remove other
OpenAL drivers, which have names of form *_oal.dll, from your Windows system and game directories. These
include the real Generic Software and Hardware drivers (typically provided by wrap_oal.dll). The idea here is that
you can remove all other OpenAL drivers from your system so that Rapture3D (provided by rapture3d_oal.dll) is
the only OpenAL driver present. You can then tell Rapture3D to masquerade as the Generic Software driver so
that games will not be aware that they are using a new driver. This allows Rapture3D to run with quite a few
OpenAL games that predate it and which don't have an option to select which OpenAL driver should be used.

Bear in mind that some game installers will reinstall the DLLs you deleted so it's worth checking after an
installation to ensure they haven't crept back.

As mentioned before, this approach is quite dangerous. It doesn't work with all OpenAL games (particularly those
that require EAX, which is deprecated and not supported by Rapture3D). You may break your game installation
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which would require a reinstall. Also, in principle deleting the wrong files from Windows system directories can
destabilise your entire system, so you might need to reinstall the whole of Windows, which is something we can't
help you with! So be really careful and only do this sort of thing if you're sure you're comfortable with the risks.

3.3.4 Buffer Configuration

The default buffer count and length can be set. A default buffer length of 256 is generally recommended, though
you may find that a length of 512, 1024 or 2048 helps if you experience stuttering. Generally, lower buffer counts
lower latency, but setting the count too low for your hardware can cause stuttering. If in doubt, just use the
defaults!

If you're wondering what "latency" means, here this is essentially the time delay between initial audio processing
and the sound being sent out of the back of your computer. We work hard to make this as quick as possible, but in
the end latency is generally limited by the quality of your audio hardware and its driver. The "advanced" edition
of Rapture3D supports ASIO-compatible studio kit which is often capable of extremely low latencies.
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3.4 The Licenses Tab

This will only appear if you're using the "User" or "Advanced" editions of Rapture3D. If you're using the "Game"
edition then Rapture3D will work with the games it was licensed for automatically, so this tab isn't needed.

If this tab is present, it should list the licenses you have. If it doesn't, you'll need to add one before you can use the
relevant software. Licenses can be added using the "Add" button. You'll need a "Rapture3D OpenAL" license to
use Rapture3D in games and you need an Internet connection to activate the license. The license comes in the
form of a hyphenated string of characters where the "XXXX-XXXX-XXXX-XXXX" is in the example above.

Licenses are available from Blue Ripple Sound.

3.4.1 How Licenses Work

Once a day, when you use Rapture3D or a similarly licensed piece of Blue Ripple Sound software, the software
"phones home" across the Internet to refresh the license. No personal information is transmitted and encryption is
used. This tab will tell you if your licenses are fresh. If they aren't, the text here will change and eventually the
software will stop working, typically a month after the last successful refresh. Some licenses (typically trial or
beta testing licenses) expire automatically and permanently, so you'll need to get another one to keep using the
software.

3.4.2 Hardware Changes

The license is stored with a short description of your machine. This means that if your machine changes, for
instance if you upgrade the CPU or switch the network card, your machine may seem to be different and license
checks may fail. The best thing to do if you're upgrading some hardware is to revoke the license before making
the change and to add it back again afterwards.

If you run into trouble, please get in touch with Blue Ripple Sound from the email address you used when buying
the software and hopefully we can sort things out.

3.4.3 Revoking Licenses

Licenses can only be used on one machine, so if you want to move your license from one machine to another you
need to revoke it. This is done with the "Revoke" button. You'll also be asked if you want to do this if you
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uninstall Rapture3D. Note that this requires an Internet connection.

If you revoke your license write it down somewhere if you haven't kept your original documentation, so you have
it to hand when you want to install Rapture3D somewhere else!

3.4.4 But Why?

We find licenses quite irritating, but the problem is that without it Rapture3D would just be far too easy to pirate
and we'd probably go out of business! So please be nice and don't try to hack it...
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4 The Rapture3D OpenAL Driver
OpenAL allows games to make use of special OpenAL "drivers" which provide 3D audio algorithms. These
algorithms may be provided in software or hardware.

Rapture3D includes a software OpenAL driver with some particularly interesting algorithms. Amongst other
things, it uses Higher Order Ambisonics for superior 3D audio spatialisation.

4.1 Using The Driver On Windows

On Windows, the driver is a special file called rapture3d_oal.dll.

4.2 Using The Driver On Mac OS X

On Mac OS X, the Rapture3D driver is a special file called libOpenAL.Rapture3D.dylib. It is configured
with the Games tab in the layout program.

Unlike Windows, Mac OS X does not have an OpenAL "router" driver to allow software to switch between
alternative OpenAL implementations, so it is tricky to change the OpenAL driver away from the default Apple
implementation without doing bad things to your system. Be careful!

4.3 Configuration

Ideally, the game will have been written to use this driver. When it hasn't, it may still be possible to make it work
by switching to it using the game's configuration screens or by replacing the system's default OpenAL driver.
However, this involves modification to system files so we cannot recommend this for ordinary users. If you do go
ahead, ensure you keep a copy of the original driver so you can return your system to its original configuration.

The driver can be configured with the "Games" tab.
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5 The Rapture3D Ambisonic Player

This edition of Rapture3D comes with an ambisonic sound file player. It uses the same layout and decoding
configuration as the Rapture3D OpenAL game engine. You'll need an "Ambisonic Playback" license, which
should be listed on the Licenses tab.

If you're not sure what ambisonics is and would like to find out, the Wikipedia article on it isn't a bad start.

If you do have ambisonic sound files around in .AMB format then well done! Hopefully you can just double-click
on them and they'll play in full 3D! The player can also handle ambisonic audio contained in a range of other file
formats, including simple Ogg/Vorbis files (.OGG or .OGA), though you'll probably want to open these directly
from the application. In these cases, channel counts are used to infer the ambisonic order (or mixed order) in the
same way as for .AMB files (so the most important cases are 4, 9 and 16 channels, corresponding to first, second
and third order).

5.1 Playlists

The left pane shows the list of files that the player is working with at the moment. You can add them with the
"Open..." or "Add..." options on the File menu. Drag and drop files to change their place in the play order and
double-click to play.

Playlists can be loaded and saved as text files using the "Playlist" menu.

5.2 Controls

The bar below the playlist can be used to jump to particular locations in the audio that is currently selected.

Below that you'll find standard player controls. These are:

Skip to previous track• 
Play/pause• 
Stop• 
Skip to next track• 
Volume• 

5.3 Status Bar

At the very bottom of the window is the status bar. This will tell you the details of the current audio that is playing
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and anything else you might need to know if there's a problem.

5.4 Visualisation

On the right hand of the player is a visualisation area. This will light up in different areas, depending on where
sounds are coming from.

In case you're interested, the visualisation is actually based on the 3D information in the stream, using a projection
similar to that used in maps of the world. Sounds playing above appear at the top in the image, sounds below
appear at the bottom, sounds at the front appear in the middle, sounds to the left of that appear to the left of centre
and so on. Sounds visualised on the left and right edges of the image are behind (the image "wraps around" at the
back, again as in a map of the world). Note that typical real recordings produce extremely complex visualisations
due to acoustic reflections.

The "View" menu gives some options to control the visualisation, including control of the quality used. Higher
quality settings put more load on your CPU.

5.5 Command-Line (Windows Only)

For those of you that use the command-line, it's worth noting that on Windows (but not Mac OS X), Rapture3D
supports some command-line options, including a full-screen mode. Run it as "Rapture3dPlayer.exe -h" to find
out more...
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6 Technical Notes

6.1 3D7.1

3D7.1 is a variant of the 7.1 surround speaker arrangement. The original 7.1 surround speaker arrangement
typically places three speakers at the front of the room, two at the sides and two at the back. Further, a subwoofer
(the ".1" in the name) is placed somewhere in the room (it doesn't matter too much where). Quite a few computers
come with 7.1 surround sound these days and there are packages for sale that allow it to be added if not. The
arrangement of the main seven speakers here puts all speakers at the same height, which is a bit of a shame when
using games where things are happening above and below!

The 3D7.1 speaker arrangement (invented by Simon N. Goodwin) is designed so that usually it can be used with
existing 7.1 sound hardware. All you have to do is change where you put your speakers. It's also designed so that
stereo material or 5.1 material will still play back well. The advantage is that games or other 3D audio software
that can handle the new speaker arrangement (e.g. via Rapture3D) can produce sound in proper full 3D!

6.1.1 Speaker Locations

Speakers should be placed as follows:

Original 7.1 Speaker Location New 3D7.1 Speaker Location
Front Left Upper Front Left
Front Right Upper Front Right
Front Centre Front Centre
Subwoofer Subwoofer
Back Left Upper Back Centre
Back Right Lower Front Centre
Side Left Lower Back Left
Side Right Lower Back Right

More mathematically, six of the speakers (ignoring the front centre and subwoofer) should form a regular
octahedron aligned so front and back faces are vertical.
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6.1.2 Configuration

Once you have your speakers set up correctly, select "Surround 3D7.1" in the Layout tab and check the speakers
are wired up correctly. You may also need to set your Windows "Advanced" sound card settings to the "7.1 home
theatre speakers" arrangement (don't use the "7.1 wide configuration speakers" setting here). You'll probably want
to use the test tones to check the speakers are in the right order after all that work!

After this you can select a Decoder as usual.
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6.2 OpenAL Developer Notes

Here are some technical notes for developers who might be interested in tuning their games to get the best out of
Rapture3D.

The Rapture3D OpenAL driver is built in software and so consists primarily of a driver dynamic library and a
configuration tool. It comes in a number of editions with different licensing schemes and features. The "Game"
edition is restricted to work only with the games it ships with.

6.2.1 OpenAL Specification

Rapture3D meets the full OpenAL 1.1 specification, including full support for alSuspendContext() and
alProcessContext() to give much better control over scene content than many drivers.

All filters support high-pass as well as low-pass options as documented in the specification.

6.2.2 Ambisonics

Rapture3D's heart is a studio-grade 3D rendering core based on Higher Order Ambisonics, running at up to fourth
order. This allows great flexibility when the audio is "decoded" for an actual speaker arrangement, including
headphones and arrangements like 3D7.1. The "advanced" edition of the software allows the use of custom
speaker arrangements.

If you're not sure what ambisonics is and would like to find out, the Wikipedia article on it isn't a bad start.

6.2.3 OpenAL Extensions

Rapture3D supports the following OpenAL extensions:

ALC_ENUMERATE_ALL_EXT• 
ALC_ENUMERATION_EXT• 
ALC_EXT_CAPTURE• 
ALC_EXT_DEDICATED• 
ALC_EXT_EFX• 
ALC_EXT_STATIC_BUFFER• 
AL_EXT_BFORMAT• 
AL_EXT_EXPONENT_DISTANCE• 
AL_EXT_FLOAT32• 
AL_EXT_FOLDBACK• 
AL_EXT_IMA4• 
AL_EXT_LINEAR_DISTANCE• 
AL_EXT_MCFORMATS• 
AL_EXT_MULAW• 
AL_EXT_MULAW_BFORMAT• 
AL_EXT_MULAW_MCFORMATS• 
AL_EXT_OFFSET• 
AL_EXT_STEREO_ANGLES• 
AL_EXT_SOURCE_RADIUS• 
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ALC_EXT_CAPTURE is only supported in the sense that the extension is present as required by the OpenAL
specification. No capture device is provided.

ALC_EXT_DEDICATED allows sounds to be sent directly to a dialogue speaker or subwoofer if one is present.

ALC_EXT_FOLDBACK is a new extension that allows the game to capture mono or stereo downmixes of the
game output, e.g. for movie clip recording.

AL_EXT_BFORMAT allows ambisonic B-Format material (WXYZ or WXY) to be used directly as game audio
assets. Such material can contain a complete pre-rendered "soundscape" that can rotate with the orientation of the
listener.

AL_EXT_STEREO_ANGLES allows stereo assets to be panned horizontally.

AL_EXT_SOURCE_RADIUS allows mono sources to change size.

6.2.4 Scaleability and CPU Load

Rapture3D has configuration options to scale CPU load to meet the hardware available. Default settings choose
sensible options if the user does not select them explicitly. The code has been tuned heavily for CPU load.

Rapture3D does not place any limits on how many sources, buffers, filters, effects or aux sends are used. The only
limit is the CPU power available on the machine used.

6.2.5 Audio Quality

All internal processing is performed using 32bit floating point operations. Sample rate conversion options include
linear and sinc interpolation. A lot of attention has gone into ensuring that control changes result in smooth audio
flow.

6.2.6 Effects

Rapture3D supports the EFX interface for effects. The deprecated EAX interfaces are not supported. The
following effects are available:

AL_EFFECT_CHORUS• 
AL_EFFECT_COMPRESSOR• 
AL_EFFECT_DEDICATED_DIALOGUE• 
AL_EFFECT_DEDICATED_LOW_FREQUENCY_EFFECT• 
AL_EFFECT_DISTORTION• 
AL_EFFECT_EAXREVERB• 
AL_EFFECT_ECHO• 
AL_EFFECT_EQUALIZER• 
AL_EFFECT_FLANGER• 
AL_EFFECT_REVERB• 
AL_EFFECT_RING_MODULATOR• 

Note that the same reverb algorithm is used for AL_EFFECT_REVERB and AL_EFFECT_EAXREVERB
although different parameters are exposed. All the available parameters are used, including the directional reverb
controls. The algorithm is an optimised high-quality ambisonic reverb, producing B-Format output directly.
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